<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.clintonnc.com/xmlrpc.php" />
<title>Every mayor in Sampson, 19 town seats up for grabs | Sampson Independent</title>

<meta name="description" content="The 2019 municipal election could see a transformation on town boards across Sampson County as 26 local seats are up for grabs, including mayoral posts in all&#8230;" />
<meta property="og:image" content="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="383" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Every mayor in Sampson, 19 town seats up for grabs | Sampson Independent" />
<meta property="og:description" content="The 2019 municipal election could see a transformation on town boards across Sampson County as 26 local seats are up for grabs, including mayoral posts in all seven of the county’s towns." />
<meta property="og:url" content="https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs" />
<meta property="og:site_name" content="Sampson Independent" />
<meta property="article:published_time" content="2019-07-03T08:00-04:00" />
<meta property="article:modified_time" content="2019-07-03T08:00-04:00" />
<meta property="og:updated_time" content="2019-07-03T08:00-04:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Every mayor in Sampson, 19 town seats up for grabs | Sampson Independent" />
<meta name="twitter:description" content="The 2019 municipal election could see a transformation on town boards across Sampson County as 26 local seats are up for grabs, including mayoral posts in all seven of the county’s towns." />
<meta name="twitter:image" content="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019.jpg" />
<meta name="twitter:image:width" content="400" />
<meta name="twitter:image:height" content="383" />
<link rel="canonical" href="https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.clintonnc.com/","name":"Sampson Independent"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.clintonnc.com/category/news","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs","name":"Every mayor in Sampson, 19 town seats up for grabs","image":"https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019.jpg"}}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Sampson Independent &raquo; Feed" href="https://www.clintonnc.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Sampson Independent &raquo; Comments Feed" href="https://www.clintonnc.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Sampson Independent &raquo; Every mayor in Sampson, 19 town seats up for grabs Comments Feed" href="https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s24477.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://s24477.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='pagepeelprocss-css' href='https://s24477.pcdn.co/wp-content/plugins/PagePeelPro/css/pagepeelpro.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css' href='https://s24477.pcdn.co/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css' href='https://s24477.pcdn.co/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css?ver=2019.05.10' type='text/css' media='all' />
<link rel='stylesheet' id='megamenu-css' href='https://s24477.pcdn.co/wp-content/uploads/maxmegamenu/style.css?ver=39112c' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://s24477.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css' href='https://s24477.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css' href='https://s24477.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://s24477.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.clintonnc.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.clintonnc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s24477.pcdn.co/wp-includes/wlwmanifest.xml" />
<link rel="alternate" type="application/json+oembed" href="https://www.clintonnc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs" />
<link rel="alternate" type="text/xml+oembed" href="https://www.clintonnc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs&#038;format=xml" />
<style type="text/css">#wpadminbar #wp-admin-bar-vfbp-toolbar-edit-form > .ab-item:before {content: "\f175";top: 2px;}#wpadminbar #wp-admin-bar-vfbp-admin-toolbar > .ab-item:before {content: "\f175";top: 2px;}</style><style type="text/css">
.mh-widget-layout4 .mh-widget-title { background: #335c4e; background: rgba(51, 92, 78, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #335c4e; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #335c4e; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #335c4e; }
</style>
<!--[if lt IE 9]>
<script src="https://s24477.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://s24477.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-32x32.png" sizes="32x32" />
<link rel="icon" href="https://s24477.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s24477.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-180x180.png" />
<meta name="msapplication-TileImage" content="https://s24477.pcdn.co/wp-content/uploads/2018/02/cropped-champfav-270x270.png" />
<style type="text/css" id="wp-custom-css">
			.attachment-mh-magazine-slider{
height: 300px !important;
width: auto !important;
}

@media only screen and (max-width: 600px) {
	div.adblade-dyna.zone-13366 {
		display: none;
	}
}		</style>
<style type="text/css">/** Mega Menu CSS: fs **/</style>
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=76281017"></script>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-40714 single-format-standard wp-custom-logo mega-menu-mh-main-nav mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-27803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27803"><a href="http://www.jobmatchnc.com/">Jobs</a></li>
<li id="menu-item-27801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27801"><a href="https://www.clintonnc.com/classifieds">Classifieds</a></li>
<li id="menu-item-34933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34933"><a href="https://mooresvillenc.circulationpro.com/scripts/WebObjects.exe/MooresvilleNCLumbertonSS">Subscribe</a></li>
<li id="menu-item-27858" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27858"><a href="https://itunes.apple.com/az/app/the-sampson-independent/id1042801126?mt=8">iPhone/Android App</a></li>
<li id="menu-item-27859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27859"><a href="https://play.google.com/store/apps/details?id=com.vervewireless.droid.sampson&#038;hl=en">Android App</a></li>
</ul></div> </nav>
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-27799" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27799"><a href="http://www.facebook.com/pages/The-Sampson-Independent/10150135730835641"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-27800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27800"><a href="http://twitter.com/SampsonInd"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
</ul></div> </nav>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.clintonnc.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="63" src="https://s24477.pcdn.co/wp-content/uploads/2018/02/cropped-clinton-1.png" class="custom-logo" alt="Sampson Independent" itemprop="logo" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-17" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><ins data-revive-zoneid="20" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div id="mega-menu-wrap-mh_main_nav" class="mega-menu-wrap"><div class="mega-menu-toggle"><div class="mega-toggle-blocks-left"></div><div class="mega-toggle-blocks-center"></div><div class="mega-toggle-blocks-right"><div class='mega-toggle-block mega-menu-toggle-block mega-toggle-block-1' id='mega-toggle-block-1' tabindex='0'><span class='mega-toggle-label' role='button' aria-expanded='false'><span class='mega-toggle-label-closed'>MENU</span><span class='mega-toggle-label-open'>MENU</span></span></div></div></div><ul id="mega-menu-mh_main_nav" class="mega-menu max-mega-menu mega-menu-horizontal mega-no-js" data-event="hover_intent" data-effect="fade_up" data-effect-speed="200" data-effect-mobile="disabled" data-effect-speed-mobile="200" data-mobile-force-width="false" data-second-click="go" data-document-click="collapse" data-vertical-behaviour="standard" data-breakpoint="600" data-unbind="true"><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-home mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-9833' id='mega-menu-item-9833'><a class="mega-menu-link" href="https://www.clintonnc.com" aria-haspopup="true" aria-expanded="false" tabindex="0">Home<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9845' id='mega-menu-item-9845'><a class="mega-menu-link" href="https://www.clintonnc.com/about-us">About Us</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9846' id='mega-menu-item-9846'><a class="mega-menu-link" href="https://www.clintonnc.com/advertise">Advertise</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9847' id='mega-menu-item-9847'><a class="mega-menu-link" href="https://www.clintonnc.com/contact-us">Contact Us</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-9851' id='mega-menu-item-9851'><a class="mega-menu-link" href="http://www.facebook.com/pages/The-Sampson-Independent/10150135730835641">Sampson Independent on Facebook</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-9852' id='mega-menu-item-9852'><a class="mega-menu-link" href="http://twitter.com/SampsonInd">Sampson Independent on Twitter</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9848' id='mega-menu-item-9848'><a class="mega-menu-link" href="https://www.clintonnc.com/reader-services">Reader Services</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9849' id='mega-menu-item-9849'><a class="mega-menu-link" href="https://www.clintonnc.com/sign-up-for-notices">Sign Up For Notices</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9850' id='mega-menu-item-9850'><a class="mega-menu-link" href="https://www.clintonnc.com/subscribe">Subscribe</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-current-post-ancestor mega-current-menu-parent mega-current-post-parent mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-9834' id='mega-menu-item-9834'><a class="mega-menu-link" href="https://www.clintonnc.com/category/news" aria-haspopup="true" aria-expanded="false" tabindex="0">News<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-16885' id='mega-menu-item-16885'><a class="mega-menu-link" href="https://www.clintonnc.com/president">President Trump</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9853' id='mega-menu-item-9853'><a class="mega-menu-link" href="https://www.clintonnc.com/archives">Archive</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9854' id='mega-menu-item-9854'><a class="mega-menu-link" href="https://www.clintonnc.com/circulars">Circulars</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-9860' id='mega-menu-item-9860'><a class="mega-menu-link" href="http://www.myinvestkit.com/www.clintonnc.com/">Finance</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9855' id='mega-menu-item-9855'><a class="mega-menu-link" href="https://www.clintonnc.com/formnewstip">Submit News Tip</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9856' id='mega-menu-item-9856'><a class="mega-menu-link" href="https://www.clintonnc.com/online-community">Online Community</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-27949' id='mega-menu-item-27949'><a class="mega-menu-link" href="https://www.clintonnc.com/category/special-sections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9857' id='mega-menu-item-9857'><a class="mega-menu-link" href="https://www.clintonnc.com/onlineforms">Online Forms</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9859' id='mega-menu-item-9859'><a class="mega-menu-link" href="https://www.clintonnc.com/subscribe">Subscribe</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-9835' id='mega-menu-item-9835'><a class="mega-menu-link" href="https://www.clintonnc.com/category/sports" aria-haspopup="true" aria-expanded="false" tabindex="0">Sports<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9861' id='mega-menu-item-9861'><a class="mega-menu-link" href="https://www.clintonnc.com/formscores">Submit Scores</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9862' id='mega-menu-item-9862'><a class="mega-menu-link" href="https://www.clintonnc.com/formsportsnews">Submit Sports News</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-12412' id='mega-menu-item-12412'><a class="mega-menu-link" href="http://pro32.ap.org/clintonnc">Pro32</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-12413' id='mega-menu-item-12413'><a class="mega-menu-link" href="http://summergames.ap.org/clintonnc">AP Olympics Coverage</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-12414' id='mega-menu-item-12414'><a class="mega-menu-link" href="http://racing.ap.org/clintonnc">Auto Racing</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-12415' id='mega-menu-item-12415'><a class="mega-menu-link" href="http://collegebasketball.ap.org/clintonnc">College Basketball</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-12416' id='mega-menu-item-12416'><a class="mega-menu-link" href="http://collegefootball.ap.org/clintonnc">College Football</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-align-bottom-left mega-menu-flyout mega-menu-item-9841' id='mega-menu-item-9841'><a class="mega-menu-link" href="http://www.legacy.com/obituaries/clintonnc" tabindex="0">Obituaries</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-9837' id='mega-menu-item-9837'><a class="mega-menu-link" href="https://www.clintonnc.com/category/opinion" aria-haspopup="true" aria-expanded="false" tabindex="0">Opinion<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9863' id='mega-menu-item-9863'><a class="mega-menu-link" href="https://www.clintonnc.com/formeditor">Submit Letter To The Editor</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-9836' id='mega-menu-item-9836'><a class="mega-menu-link" href="https://www.clintonnc.com/category/features" aria-haspopup="true" aria-expanded="false" tabindex="0">Features<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-11715' id='mega-menu-item-11715'><a class="mega-menu-link" href="https://www.clintonnc.com/games">Games & Puzzles</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9864' id='mega-menu-item-9864'><a class="mega-menu-link" href="https://www.clintonnc.com/comics">Comics</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9865' id='mega-menu-item-9865'><a class="mega-menu-link" href="https://www.clintonnc.com/contests">Contests</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9866' id='mega-menu-item-9866'><a class="mega-menu-link" href="https://www.clintonnc.com/horoscopes">Horoscopes</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-27950' id='mega-menu-item-27950'><a class="mega-menu-link" href="https://www.clintonnc.com/category/special-sections">Special Sections</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9869' id='mega-menu-item-9869'><a class="mega-menu-link" href="https://www.clintonnc.com/formanniversary">Submit Anniversary</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9870' id='mega-menu-item-9870'><a class="mega-menu-link" href="https://www.clintonnc.com/formbirth">Submit Birth</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9871' id='mega-menu-item-9871'><a class="mega-menu-link" href="https://www.clintonnc.com/formbirthday">Submit Birthday</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9872' id='mega-menu-item-9872'><a class="mega-menu-link" href="https://www.clintonnc.com/formengagement">Submit Engagement</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9873' id='mega-menu-item-9873'><a class="mega-menu-link" href="https://www.clintonnc.com/formwedding">Submit Wedding</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-9839' id='mega-menu-item-9839'><a class="mega-menu-link" href="https://www.clintonnc.com/calendar" tabindex="0">Calendar</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-9840' id='mega-menu-item-9840'><a class="mega-menu-link" href="https://www.clintonnc.com/entertainment" aria-haspopup="true" aria-expanded="false" tabindex="0">Entertainment<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9879' id='mega-menu-item-9879'><a class="mega-menu-link" href="https://www.clintonnc.com/tvlistings">TV Listings</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9874' id='mega-menu-item-9874'><a class="mega-menu-link" href="https://www.clintonnc.com/games">Games</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9877' id='mega-menu-item-9877'><a class="mega-menu-link" href="https://www.clintonnc.com/tvsoaps">Soaps</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9882' id='mega-menu-item-9882'><a class="mega-menu-link" href="https://www.clintonnc.com/tvsports">TV Sports</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9875' id='mega-menu-item-9875'><a class="mega-menu-link" href="https://www.clintonnc.com/tvmovies">Movies</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9876' id='mega-menu-item-9876'><a class="mega-menu-link" href="https://www.clintonnc.com/tvqa">Q &#038; A</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9880' id='mega-menu-item-9880'><a class="mega-menu-link" href="https://www.clintonnc.com/tvnews">TV News</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9878' id='mega-menu-item-9878'><a class="mega-menu-link" href="https://www.clintonnc.com/tvbestbets">TV Best Bets</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9883' id='mega-menu-item-9883'><a class="mega-menu-link" href="https://www.clintonnc.com/tvtalk">TV Talk</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9884' id='mega-menu-item-9884'><a class="mega-menu-link" href="https://www.clintonnc.com/tvvideo">TV Video</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-9881' id='mega-menu-item-9881'><a class="mega-menu-link" href="https://www.clintonnc.com/tvsearch">TV Search</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-26637' id='mega-menu-item-26637'><a class="mega-menu-link" href="http://local.clintonnc.com" aria-haspopup="true" aria-expanded="false" tabindex="0">Businesses<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-26596' id='mega-menu-item-26596'><a class="mega-menu-link" href="https://www.clintonnc.com/advertise">Advertise With Us</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-9838' id='mega-menu-item-9838'><a class="mega-menu-link" href="http://local.clintonnc.com">Business Directory</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-26594' id='mega-menu-item-26594'><a class="mega-menu-link" href="https://www.clintonnc.com/advertiser-pay">Advertiser Pay</a></li></ul>
</li></ul></div> </nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom">
News Ticker<i class="fa fa-chevron-right"></i> </div>
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom"> <li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.clintonnc.com/news/40717/lakewood-ffa-first-in-parli-pro" title="Lakewood FFA first in Parli Pro">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ July 3, 2019 ] </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Lakewood FFA first in Parli Pro </span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News </span>
</a>
</li> <li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs" title="Every mayor in Sampson, 19 town seats up for grabs">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ July 3, 2019 ] </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Every mayor in Sampson, 19 town seats up for grabs </span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Local </span>
</a>
</li> <li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.clintonnc.com/sports/40712/40712" title="Clinton, East Duplin set for winner-takes-all tiebreaker">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ July 3, 2019 ] </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Clinton, East Duplin set for winner-takes-all tiebreaker </span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Sports </span>
</a>
</li> <li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.clintonnc.com/news/40710/towns-to-celebrate-fourth" title="Towns to celebrate Fourth">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ July 3, 2019 ] </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Towns to celebrate Fourth </span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News </span>
</a>
</li> <li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.clintonnc.com/news/40707/cvb-announces-capital-grant-enrollment" title="CVB announces Capital Grant enrollment">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ July 3, 2019 ] </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
CVB announces Capital Grant enrollment </span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News </span>
</a>
</li> </ul>
</div>
</div> </div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside zoomdSearch='{"trigger":"OnClick"}' class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://www.clintonnc.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.clintonnc.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://www.clintonnc.com/category/news">News</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.clintonnc.com/category/news/local" itemprop="url"><span itemprop="title">Local</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Every mayor in Sampson, 19 town seats up for grabs</nav>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs"
  },
  "headline": "Every mayor in Sampson, 19 town seats up for grabs",
        "image": "https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019.jpg",
     "datePublished": "2019-07-03T08:00:13-04:00",
  "dateModified": "2019-07-03T08:00:13-04:00",
  "author": {
    "@type": "Person",
	    "name": "By Chris Berendt - cberendt@clintonnc.com"
	  },
   "publisher": {
    "@type": "Organization",
    "name": "Sampson Independent",
    "logo": {
      "@type": "ImageObject",
      "url": "http://s24477.p831.sites.pressdns.com/wp-content/uploads/2016/05/clinton.png"
    }
  },
  "description": "<div class="mh-excerpt"><p>The 2019 municipal election could see a transformation on town boards across Sampson County as 26 local seats are up for grabs, including mayoral posts in all seven of the county&#8217;s towns. Filing for November&#8217;s <a class="mh-excerpt-more" href="https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs" title="Every mayor in Sampson, 19 town seats up for grabs">[&#8230;]</a></p>
</div>"
}
</script>
<style>
.neFileBlock{
	display:none;
}
</style>
<article id="post-40714" class="post-40714 post type-post status-publish format-standard has-post-thumbnail hentry category-local category-news category-top-stories">
<header class="entry-header clearfix"><h1 class="entry-title">Every mayor in Sampson, 19 town seats up for grabs</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.clintonnc.com/date/2019/07">July 3, 2019</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.clintonnc.com/author/englewoodindependent-2">Sampson Independent</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.clintonnc.com/category/news/local" rel="category tag">Local</a>, <a href="https://www.clintonnc.com/category/news" rel="category tag">News</a>, <a href="https://www.clintonnc.com/category/top-stories" rel="category tag">Top Stories</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs#respond" class="mh-comment-count-link"><span class="dsq-postid" data-dsqidentifier="40714 https://www.clintonnc.com/?p=40714">0</span></a></span>
</div>
<div id="byline" style="margin-left: 5px; margin-top: 5px;"><b> By Chris Berendt - <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1370717661767d776753707f7a7d677c7d7d703d707c7e">[email&#160;protected]</a></b></div>
</header>
<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019-400x381.jpg" alt="" title="web1_election2019.jpg" />
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs&t=Every+mayor+in+Sampson%2C+19+town+seats+up+for+grabs', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Every+mayor+in+Sampson%2C+19+town+seats+up+for+grabs:&url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs&media=https://www.clintonnc.com/wp-content/uploads/2019/07/web1_election2019.jpg&description=Every+mayor+in+Sampson%2C+19+town+seats+up+for+grabs', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="/cdn-cgi/l/email-protection#122d616770787771662f576477606b3720227f736b7d603720227b7c37202241737f62617d7c372051372022232b372022667d657c37202261777366613720226762372022747d60372022756073706134737f6229707d766b2f7a666662613721533720543720546565653c717e7b7c667d7c7c713c717d7f3720547c7765613720542622252326372054776477606b3f7f736b7d603f7b7c3f61737f62617d7c3f232b3f667d657c3f61777366613f67623f747d603f7560737061" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
</div></div>
<div style="float:left; width:200px;  margin:7px;">
<div>
<a href="#" onclick="window.open('https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019.jpg','Photo','width=600,height=400')"><img src="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019.jpg" style="float:left; width:200px; margin-top:3px; margin-bottom:3px"></a></a>
- <span style="font-size:11px;"></span>
</div>
</div>
<p>The 2019 municipal election could see a transformation on town boards across Sampson County as 26 local seats are up for grabs, including mayoral posts in all seven of the county&#8217;s towns.</p>
<p>Filing for November&#8217;s municipal election kicks off at noon this Friday, July 5. The two-week filing period will conclude at noon July 19. Town board members are all elected to four-year terms. Mayoral terms are two years in Autryville, Clinton, Garland and Newton Grove, and four years in Roseboro, Salemburg and Turkey.</p>
<p>In Autryville, Larry D. Autry&#8217;s mayoral term is expiring, as are the commissioner terms of Carolyn Cashwell, Dana Hairr and Larry Bernstein. Autry, formerly a town commissioner for the town, was elected to the mayoral post in 2015 and reelected in 2017.</p>
<p>In Clinton, Mayor Lew Starling is expected to file first thing Friday to seek his 10th term in office. Along with Starling, the terms of District 2 Councilman Neal Strickland and District 4 Councilwoman Jean Turlington are coming to an end. Starling has been unopposed for mayor since first running for election to the office 18 years ago against longtime Mayor Emsley Kennedy, who held the office for 28 years.</p>
<p>In Garland, Mayor Winifred Murphy and two commissioners &#8212; Mary Brown and Ralph Smith &#8212; are seeing their terms come to their natural end, while a third abbreviated commissioner term will also be up for grabs. Austin Brown, elected as Garland&#8217;s youngest ever commissioner in 2017 and later becoming its youngest mayor pro tem, resigned last month.</p>
<p>According to Sampson Board of Elections director Ashley Tew, Brown&#8217;s unexpired term will necessitate a completely separate contest, and will be spelled out on the ballot as such. There will be contest for mayor, a contest for the two four-year commissioner terms and then a contest for the unexpired commissioner term, which will expire as scheduled in 2021.</p>
<p>Tew cited a statute that explains, in essence, that in the case of a resignation or death of a serving board member, that board shall appoint someone until the next scheduled election, at which point the elected person fills the term. With Brown resigning just before the filing period, Garland is poised to let the election process play out.</p>
<p>Murphy would be seeking her fourth term in office as Garland&#8217;s mayor, if she ultimately chooses to do so. She was elected as commissioner in November 2011, appointed as mayor in 2012 and elected to the post in 2013 &#8212; the first ever African-American to serve in the role. She was subsequently reelected in 2015 and 2017.</p>
<p>Down in Harrells, three aldermen are up for election, including James Moore, Johnny &#8220;Ray&#8221; Powell and Katie Greer. The mayor is not decided by the people in Harrells. Aldermen are elected and they are responsible for choosing who among them will be mayor. Moore has served in that capacity for nearly two decades.</p>
<p>Up in Newton Grove, Mayor Gerald Darden and commissioners Alan Herring and Cody Smith are each seeing their terms expire in 2019. Darden was the mayor of Newton Grove for 12 years before stepping down in 2013. He ran successfully in 2015 to take back his mayoral seat, to which he was reelected in 2017.</p>
<p>In Roseboro, Mayor Alice Butler will see her first term come to an end, along with town commissioners Ray Clark Fisher and Cary Holland. Butler made history back in 2015 when she became the first female mayor of Roseboro, succeeding longtime mayor David Alexander.</p>
<p>Salemburg and Turkey wrap up a packed election.</p>
<p>In Salemburg, Mayor Joe Warren is wrapping up his first term at the town&#8217;s helm, and it remains to be seen whether there will be another. Warren ran unopposed four years ago in taking the reins from longtime mayor and mentor Bobby Strickland. Along with Warren, the four-year terms of commissioners Shirley Cooper, Mack Honeycutt and Bobby Tew are expiring.</p>
<p>In Turkey, Donald Myers&#8217; four-year mayoral term is nearing its conclusion. He was first elected back in 2015, the same year commissioners Wilbert &#8220;Max&#8221; Pope and Mike Smith took their seats on the town board. The posts for Pope and Smith will also be up for grabs.</p>
<p>The one-stop early voting period will extend from Oct. 16 to Nov. 1 leading up to Election Day on Nov. 5.</p>
<p><strong>Autryville alcohol sales</strong></p>
<p>It remains to be seen whether there will be a vote on a beer and wine referendum in Autryville.</p>
<p>The town board voted unanimously back in November 2018 to put a measure on the ballot for the sale of beer and unfortified wine with off-site consumption. Two public hearings have since been held and inquiries by the town to the Sampson County Board of Elections have been made, however Tew said this week ballot language had yet to be received.</p>
<p>The process for the ABC referendum is between the town&#8217;s board and the ABC Commission, Tew has noted. There are a number of steps that need to be taken by the town, which is responsible for providing local elections officials with the approved language that is then transferred to the ballot.</p>
<p>Only registered municipal voters in Autryville &#8212; there are just 128 &#8212; would vote on any beer and wine referendum for the town.</p>
<style>
.neFileBlock {
	margin-bottom: 20px;
}
.neFileBlock p {
	margin: 0px 0px 0px 0px;
}
.neFileBlock .neFile {
	border-bottom: 1px dotted #aaa;
	padding-bottom: 5px;
	padding-top: 10px;
}
.neFileBlock .neCaption {
	font-size: 85%;
}
</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_election2019.jpg"></p>
<div class="neCaption"></div>
</div>
<div class="metaInfo"><photo0>https://www.clintonnc.com/wp-content/uploads/2019/07/web1_election2019.jpg</photo0><caption0></caption0><photoCredit0></photoCredit0></div>
</div>
<div class="metaInfo"><subheadMeta>Filing period kicks off Friday</subheadMeta></div>
<div class="metaInfo"><bylineMeta></p>
<p>By Chris Berendt</p>
<p><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7516171007101b11013516191c1b011a1b1b165b161a18">[email&#160;protected]</a></p>
<p></bylineMeta></div>
<div class="metaInfo"><factboxMeta></p>
<p><strong>Municipal Election 2019</strong></p>
<p>Below is a full list of town mayors and board members whose terms are expiring this year. Filing for November&#8217;s municipal election kicks off at noon this Friday, July 5. Total seats expiring in parentheses.</p>
<p><strong>Autryville (mayor, three commissioners)</strong></p>
<p>Larry D. Autry &#8212; mayor</p>
<p>Carolyn Cashwell &#8212; commissioner</p>
<p>Dana Hairr &#8212; commissioner</p>
<p>Larry Bernstein &#8212; commissioner</p>
<p><strong>Clinton (mayor, two Council seats)</strong></p>
<p>Lew Starling &#8212; mayor</p>
<p>Neal Strickland &#8212; Dist. 2 Council</p>
<p>Jean Turlington &#8212; Dist. 4 Council</p>
<p><strong>Garland (mayor, three commissioners)</strong></p>
<p>Winifred Murphy &#8212; mayor</p>
<p>Mary Brown &#8212; commissioner</p>
<p>Ralph Smith &#8212; commissioner</p>
<p>Austin Brown &#8212; unexpired term commissioner</p>
<p><strong>Harrells (three aldermen)</strong></p>
<p>James Moore &#8212; alderman (current mayor)</p>
<p>Johnny &#8220;Ray&#8221; Powell &#8212; alderman</p>
<p>Katie Greer &#8212; alderman</p>
<p><strong>Newton Grove (mayor, two commissioners)</strong></p>
<p>Gerald Darden &#8212; mayor</p>
<p>Alan Herring &#8212; commissioner</p>
<p>Cody Smith &#8212; commissioner</p>
<p><strong>Roseboro (mayor, two commissioners)</strong></p>
<p>Alice Butler &#8212; mayor</p>
<p>Ray Clark Fisher &#8212; commissioner</p>
<p>Cary Holland &#8212; commissioner</p>
<p><strong>Salemburg (mayor, three commissioners)</strong></p>
<p>Joseph A. Warren Jr. &#8212; mayor</p>
<p>Shirley Cooper &#8212; commissioner</p>
<p>Mack Honeycutt &#8212; commissioner</p>
<p>Bobby Tew &#8212; commissioner</p>
<p><span style="font-family: Calibri,sans-serif; color: #1f497d; font-size: small;"><span style="font-size: 11pt;"></span></span><strong>Turkey (mayor, two commissioners)</strong></p>
<p>Donald Meyers &#8212; mayor</p>
<p>Wilbert &#8220;Max&#8221; Pope &#8212; commissioner</p>
<p>Mike Smith &#8212; commissioner</p>
<p></factboxMeta></div>
<div class="metaInfo"><shirttailMeta></p>
<p>Editor Chris Berendt can be reached at 910-592-8137 ext. 2587.</p>
<p></shirttailMeta></div>
<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs&t=Every+mayor+in+Sampson%2C+19+town+seats+up+for+grabs', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Every+mayor+in+Sampson%2C+19+town+seats+up+for+grabs:&url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs&media=https://www.clintonnc.com/wp-content/uploads/2019/07/web1_election2019.jpg&description=Every+mayor+in+Sampson%2C+19+town+seats+up+for+grabs', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.clintonnc.com%2Fnews%2F40714%2Fevery-mayor-in-sampson-19-town-seats-up-for-grabs', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="/cdn-cgi/l/email-protection#fcc38f899e96999f88c1b98a998e85d9cecc919d85938ed9cecc9592d9ceccaf9d918c8f9392d9cebfd9cecccdc5d9cecc88938b92d9cecc8f999d888fd9cecc898cd9cecc9a938ed9cecc9b8e9d9e8fda9d918cc79e939885c19488888c8fd9cfbdd9cebad9ceba8b8b8bd29f909592889392929fd29f9391d9ceba92998b8fd9cebac8cccbcdc8d9ceba998a998e85d1919d85938ed19592d18f9d918c8f9392d1cdc5d188938b92d18f999d888fd1898cd19a938ed19b8e9d9e8f" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
</div></div>
<p>Editor Chris Berendt can be reached at 910-592-8137 ext. 2587.</p> </div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.clintonnc.com/sports/40712/40712" rel="prev"><img width="80" height="60" src="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_Dixie-Youth-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" /><span>Previous</span><p>Clinton, East Duplin set for winner-takes-all tiebreaker</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.clintonnc.com/news/40717/lakewood-ffa-first-in-parli-pro" rel="next"><img width="80" height="60" src="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_FFA_1-80x60.jpeg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_FFA_1-80x60.jpeg 80w, https://s24477.pcdn.co/wp-content/uploads/2019/07/web1_FFA_1-326x245.jpeg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Next</span><p>Lakewood FFA first in Parli Pro</p></a></div>
</nav>
<ins class="adbladeads" data-cid="35553-1462681351" data-host="web.adblade.com" data-tag-type="4" data-subid="www.clintonnc.com" data-protocol="https" style="display:none"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://web.adblade.com/js/ads/async/show.js" type="text/javascript"></script>
<a id="comments"></a>
<div id="disqus_thread"></div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-4" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><a href="http://www.accuweather.com/en/us/clinton-nc/28328/weather-forecast/334881" class="aw-widget-legal">

</a><div id="awcc1464048857800" class="aw-widget-current" data-locationkey="334881" data-unit="f" data-language="en-us" data-useip="false" data-partner="civitas" data-uid="awcc1460129762895" data-targeturl="https://www.clintonnc.com/weather"></div><script async type="text/javascript" src="https://oap.accuweather.com/launch.js"></script>
<ins data-revive-zoneid="111" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="16" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-23" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"></div></div><div id="custom_html-8" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="17" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script> </div></div><div id="custom_html-24" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">National Video</span></h4><div class="textwidget custom-html-widget"><div class="inform-embed" data-type="VideoLauncher/Slider" data-tracking-group="92975"></div>
<script type="text/javascript">_informq.push(['embed']); vid.muted = true;</script>
<script src="https://launch.inform.com/js/embed.js"></script></div></div><div id="custom_html-11" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Most Commented</span></h4><div class="textwidget custom-html-widget"><style>
				.dsq-widget-list{
				padding-left:0px;
				}
				.dsq-widget-item{
				margin:0px;
				border-top-right-radius: 4px;
				border-top-left-radius: 4px;
				border-top: 1px solid #DDD;
				border-bottom: 1px solid #DDD;
				margin:0px !important;
				padding: 10px 15px;
				}
				.dsq-widget-thread{
				color:#333;						
				}
			</style>
<script type="text/javascript" src="//disqus.com/forums/sampsonindependent/popular_threads_widget.js?num_items=3&num_days=5"></script></div></div><div id="custom_html-13" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="18" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script> </div></div><div id="custom_html-14" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><ins data-revive-zoneid="19" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script> </div></div> </aside> </div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="http://championcarolinas.com"><img width="300" height="81" src="https://s24477.pcdn.co/wp-content/uploads/2018/02/championwhite-300x81.png" class="image wp-image-27792  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" /></a></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="nav_menu-2" class="mh-footer-widget widget_nav_menu"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">General Information</span></h6><div class="menu-general-information-container"><ul id="menu-general-information" class="menu"><li id="menu-item-27796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27796"><a href="https://www.clintonnc.com/advertise">Advertise with the Sampson Independent</a></li>
<li id="menu-item-27797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27797"><a href="https://www.clintonnc.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-27798" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27798"><a href="https://www.clintonnc.com/sign-up-for-notices">Sign Up For Headline E-Mails</a></li>
</ul></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="recent-posts-2" class="mh-footer-widget widget_recent_entries"> <h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Recent Articles</span></h6> <ul>
<li>
<a href="https://www.clintonnc.com/news/40717/lakewood-ffa-first-in-parli-pro">Lakewood FFA first in Parli Pro</a>
</li>
<li>
<a href="https://www.clintonnc.com/news/40714/every-mayor-in-sampson-19-town-seats-up-for-grabs">Every mayor in Sampson, 19 town seats up for grabs</a>
</li>
<li>
<a href="https://www.clintonnc.com/sports/40712/40712">Clinton, East Duplin set for winner-takes-all tiebreaker</a>
</li>
<li>
<a href="https://www.clintonnc.com/news/40710/towns-to-celebrate-fourth">Towns to celebrate Fourth</a>
</li>
<li>
<a href="https://www.clintonnc.com/news/40707/cvb-announces-capital-grant-enrollment">CVB announces Capital Grant enrollment</a>
</li>
</ul>
</div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="text-2" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact</span></h6> <div class="textwidget"><p><strong>Call:</strong><br />
T: 910-592-8137<br />
F: 10-592-8756<br />
<strong>Address:</strong><br />
109 W. Main St.<br />
Clinton NC, 28328</p>
</div>
</div><div id="custom_html-15" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//nextmillennium.liqwid.net/?key=D85D-A6F1-B041-B88A'; var x=document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s,x);})();
</script></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
2018 Champion Media </p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div>
<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-6686294-35']);
						_gaq.push(['_trackPageview']);
			(function() {
			 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script><script type='text/javascript' src='https://s24477.pcdn.co/wp-content/plugins/PagePeelPro/js/raphael-min.js?ver=1.3.5'></script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-content/plugins/PagePeelPro/js/raphael-blur.js?ver=1.3.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PagePeelProParams = {"smallImageUrl":["https:\/\/www.clintonnc.com\/wp-content\/uploads\/2019\/06\/CLNRC2019-Sm.png"],"largeImageUrl":["https:\/\/www.clintonnc.com\/wp-content\/uploads\/2019\/06\/CLNRC2019-Lg.png"],"peelColorStart":["#ff0000"],"peelColorEnd":["#7d0096"],"pagePeelTargetUrl":["https:\/\/sampsonind.secondstreetapp.com\/Sampson-Independents-Readers-Choice-2019"],"pagePeelActivateEvent":["hover"],"openInNewWindow":["on"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-content/plugins/PagePeelPro/js/pagepeelpro.js?ver=1.3.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"sampsonindependent"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"40714 https:\/\/www.clintonnc.com\/?p=40714","disqusShortname":"sampsonindependent","disqusTitle":"Every mayor in Sampson, 19 town seats up for grabs","disqusUrl":"https:\/\/www.clintonnc.com\/news\/40714\/every-mayor-in-sampson-19-town-seats-up-for-grabs","postId":"40714"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.7.1.4'></script>
<script type='text/javascript' src='https://s24477.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"62f380209b","applicationID":"309219189","transactionName":"ZlNUNxdQWhZTWk0KWl8ZdwARWFsLHUpQDVJdUw==","queueTime":0,"applicationTime":166,"atts":"ShRXQV9KSRg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>